[Stackless] strange bug with weakref on main tasklet

Kristján Valur Jónsson kristjan at ccpgames.com
Thu Dec 13 11:02:13 CET 2007


I wasn't able to repro using your code.  I tried compiling without object malloc and running within purify but no errors are reported.
I also tried to explicitly call gc.collect() to trigger a collection.

What I don't understand is why stackless.main() should be garbage collected at all?  The main tasklet should never die.

I suspect that there is something curious going on in the rest of the code that you have and the gc thing is just a red herring.  You can verify that by using your own weakref and hook into its deletion callback.  See if your tasklet is ever actually deleted and the weakref is cleared.

Perhaps you can supply me with the rest of the (crashing) module and I can give it a go with purify.

K

> -----Original Message-----
> From: stackless-bounces at stackless.com [mailto:stackless-
> bounces at stackless.com] On Behalf Of Andrew Dalke
> Sent: Tuesday, December 11, 2007 02:33
> To: Stackless mailing list
> Subject: [Stackless] strange bug with weakref on main tasklet
>
> This appears to be a memory bug which requires everything to be in
> just the right place to trigger the error.  My code starts
>





More information about the Stackless mailing list