[Stackless] threading.Lock() Doesn't Work

Richard Tew richard.m.tew at gmail.com
Wed Jun 13 12:26:33 CEST 2007


On 6/12/07, Seun Osewa <seun.osewa at gmail.com> wrote:
> I'm facing a very puzzling problem.  Each time I try to run any
> multi-threaded program on my Stackless Python (windows) 2.5.1 I get an
> error.
>
> In file \lib\Queue.py, "self.mutex=threading.Lock()"
> AttributeError: 'module' object has no attribute 'Lock'
>
> If I run the same scripts with -O, they run, but a script that Depends
> on the Queue class causes Python to hang.  I'm wondering if some bad
> interaction between Python and Stackless is causing this?

Hi Seun,

Some questions:

 1. Is there any chance you can provide the simplest possible
reproduction case you can come up with?
 2. Are you using the prebuilt binaries from stackless.com or did you
compile Stackless yourself?

I assumed that if Lock was not available the following would fail (I
did it in the Python interpreter):

     >>> import threading
     >>> threading.Lock
     <built-in function allocate_lock>
     >>>

Do this fail for you?  If it does then unfortunately the problem is on
your end.  I suspect this is the case, otherwise there would have been
indications of wider problems in the test suite when I ran it after I
compiled the binaries.

Cheers,
Richard.

_______________________________________________
Stackless mailing list
Stackless at stackless.com
http://www.stackless.com/mailman/listinfo/stackless



More information about the Stackless mailing list