[Stackless] Sockets

Rod userprogoogle-139 at yahoo.co.uk
Thu Mar 29 11:29:09 CEST 2007


I am new to the Stackless way of things but overall so far so good. However I am trying to write a programme which uses sockets and so far have had no luck. I keep receiving errors. Also I have tried running the mud.py example which is no the wiki and again I receive errors, a copy of which I have put below. I am using Python 2.4 and stackess 3.1b3 - Win XP. I have also downloaded the stacklesssocket library and have been using that. Any advice on using sockets will be gratefully received as I am at a loss to know why my old sockets model (which worked fine without stackless), which I ported to Stackless no longer works. Also is there any particular reason why no sockets code I try (even from stackless.com) works?



Accepting connections on 53757
main error
Traceback (most recent call last):
  File "C:\Dokumente und Einstellungen\McCall\Desktop\mud.py", line 168, in ?
  File "C:\Python24\lib\stacklesssocket.py", line 59, in ManageSockets
  File "C:\Python24\lib\asyncore.py", line 111, in poll
    is_w = obj.writable()
  File "C:\Python24\lib\stacklesssocket.py", line 140, in writable
    if self.socket.type != SOCK_DGRAM and not self.connected:
AttributeError: '_socketobject' object has no attribute 'type'
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stackless.com/pipermail/stackless/attachments/20070329/adc3ff47/attachment.htm>
-------------- next part --------------
Stackless mailing list
Stackless at stackless.com

More information about the Stackless mailing list