[Stackless] Stackless Python 2.5.1 fails regression tests

Richard Tew richard.m.tew at gmail.com
Wed Sep 19 10:28:00 CEST 2007


On 9/19/07, Ad Killer <adkiller at post.com> wrote:
> I've recently upgraded to Stackless Python 2.5.1 and have been experiencing some problems. I've been trying to execute the regression tests but have so far experienced crashes. I've tried using the prebuilt binary from http://www.stackless.com/binaries/stackless-python-251.zip with ActivePython v2.5.1.1. I've also tried rebuilding from scratch using the sources from http://svn.python.org/projects/stackless/branches/release25-maint/ with no luck in resolving the problem.
>
> Has anybody here run the regression tests (python25 testall.py) with any problems?

I never run the tests on a Python installation which had the Stackless
files added to it.  The reason for this is that I generally install to
Program Files\Python25 and the tests cannot handle spaces in directory
names.

But when I compile Stackless, I normally run the tests in the source
tree.  For instance in the directory release25-maint, which has been
compiled with Visual Studio:

PCBuild\python.exe Lib\test\regrtest.py
cd Stackless\unittests
..\..\PCBuild\python.exe runall.py

Both the regression tests and the Stackless unittests pass or I do not
upload the binaries.

There is no reason to expect the binaries to work in place for
ActivePython.  Lord knows what shenanigans going into making that,
which aren't involved in the compilation of the normal installer on
python.org.

Cheers,
Richard.




More information about the Stackless mailing list