[Stackless] Running stackless on Python 2.4.3

Christian Tismer tismer at stackless.com
Fri Sep 21 00:36:24 CEST 2007


j j wrote:
> Do I have to have Python 2.4.4 or can I just run stackless 2.4.4
> download package on python 2.4.3?

It might work to mix certain binary downloads of different versions,
but this is completely by chance, and any guarantees are voidened, 
immediately.
Well, there ain't any guarantees at all, but this way they are
even less.

I should better say "you must install the exactly correct version
of the patch for your system", and I should check that it is so.

You are replacing the core of the interpreter, and that includes some
tiny differences of some data structures.
I have to add that in most cases, extension modules might work,
but before complaining, please try compiling the extension, first.

cheers - chris
-- 
Christian Tismer             :^)   <mailto:tismer at stackless.com>
tismerysoft GmbH             :     Have a break! Take a ride on Python's
Johannes-Niemeyer-Weg 9A     :    *Starship* http://starship.python.net/
14109 Berlin                 :     PGP key -> http://wwwkeys.pgp.net/
work +49 30 802 86 56  mobile +49 173 24 18 776  fax +49 30 80 90 57 05
PGP 0x57F3BF04       9064 F4E1 D754 C2FF 1619  305B C09C 5A3B 57F3 BF04
       whom do you want to sponsor today?   http://www.stackless.com/




More information about the Stackless mailing list