[Stackless] trying to include zlib into stackless library

Biberdorf, Terry Terry.Biberdorf at spectrumdsi.com
Tue Jan 13 21:48:19 CET 2009


Hi Henk, Stackless,

Thanks for the advice, but I am still having problems (and return errors of: "can't decompress data; zlib not available")

I am not sure where I am going wrong.

my current project directory structure is as follows:
.../Stackless/SCStackless/    <-- where my project will be built
.../Stackless/zlib/zlib-1.2.3/libz.a    <-- where my zlib library was built
.../Stackless/python-2.6.1-stackless/  <-- where I saved the stackless source code.
.../Stackless/Stackless261/   <-- target directory to build stackless 2.6.1 in.

then in my Stackless261 directory I issued the following configuration command:
../python-2.6.1-stackless/configure AR=arm-elf-ar --verbose --with-threads=no --build=i686-pc-cygwin --host=arm-elf LDFLAGS="-mlittle-endian -mthumb-interwork" BASECFLAGS="-DOAT_BUILD -fno-inline -g -mlittle-endian -mthumb-interwork" --with-zlib

I've tried --with-zlib=... and it hasn't appeared to do anything - The zlib module is not getting included into Modules/config.c. Looking further into Modules/Setup, it appears to be a mostly deprecated mechanism for selecting extensions. I've found references to setup.py, but it's not being run.

What is the next step?

Thank you,
- Terry
________________________________________
From: Henk Punt [henkpunt at gmail.com]	
Sent: Monday, January 12, 2009 7:27 AM
To: Biberdorf, Terry
Subject: Re: [Stackless] trying to include zlib into stackless library

I usually add

--with-zlib=/usr/include

to the configure command line before makeing.

that works for me...


On Mon, Jan 12, 2009 at 1:56 PM, Biberdorf, Terry
<Terry.Biberdorf at spectrumdsi.com> wrote:
> Hi all
>
> I am attempting to include zlib into my stackless library build for my arm9 system.
>
> Can someone please help me with the proper procedure.  What I am currently doing is editing the source tree file, python-2.6.1-stackless/Modules/Setup.dist and remove the commented out line for zlib.
>
> Then in my target directory I run configure.  I can see by my Makefile that zlib modules are now included, but after I build my library, I find that specific modules are no longer included in my newly created libary, ie. "getcwd"
>
> I am following the correct process to include new modules?
>
> Thanks
>
>
>
> _______________________________________________
> Stackless mailing list
> Stackless at stackless.com
> http://www.stackless.com/mailman/listinfo/stackless
>




More information about the Stackless mailing list