[Stackless] Having building problems under Cygwin

Austin, Alex Alex.Austin at spectrumdsi.com
Wed Jan 21 23:27:56 CET 2009

It is a python issue. Raw python-2.6.1 has the same problem.

- Alex

-----Original Message-----
From: Richard Tew [mailto:richard.m.tew at gmail.com] 
Sent: Wednesday, January 21, 2009 8:05 AM
To: Austin, Alex
Cc: Stackless Mailing List
Subject: Re: [Stackless] Having building problems under Cygwin

On Tue, Jan 20, 2009 at 5:59 PM, Austin, Alex
<Alex.Austin at spectrumdsi.com> wrote:
> I'm trying to build stackless without thread support, but with tasklet
> support, in order to emulate an embedded system I'm trying to port stackless
> to.

Here are a range of things you can do to gather more information about
the cause of these unexpected errors:

Download and compile the standard Python 2.6.1 source code with the
same options.  Did you get the same error?  If so then Python itself
does not like your compilation environment.  You need to talk to
standard Python people about this.  Tell us that this was the reason
anyway so people in future can find the solution in our mailing list

If it did not error, then compile the Stackless source code again with
STACKLESS_OFF defined.  This should compile it as standard Python and
should also compile without errors because the disabling of the
Stackless functionality should leave it exactly the same as standard
Python of the same version.  Did you get the same error anyway?  Any
errors? If so then this means we have mismerged Stackless.  Come back
and tell us as much as you can about it and we'll look into it.

At this point, you should be able to compile standard Python with your
options and you should be able to compile Stackless as standard Python
with your options.  But you can't compile Stackless normally because
of the original errors you gave.

The next step is to try and compile Stackless with threading enabled.
Did you get the same error?  Any errors?

Anyway, let us know how it goes.


More information about the Stackless mailing list