[Stackless] assert in schedule_task_destruct

Manley, Tom Tom.Manley at spectrumdsi.com
Thu May 7 19:17:09 CEST 2009

Hi Richard,

To hit the assert I start the interpreter from VS2K8, import stackless, and then paste the commands into the interpreter. I just tried recreating your steps by putting the commands in a script and running it directly, and that worked fine, i.e. does not assert. I also tried starting the interpreter from VS2K8 and importing the script and it worked there as well. 


-----Original Message-----
From: Richard Tew [mailto:richard.m.tew at gmail.com] 
Sent: Thursday, May 07, 2009 11:37 AM
To: Manley, Tom
Cc: stackless at stackless.com
Subject: Re: [Stackless] assert in schedule_task_destruct

On Thu, May 7, 2009 at 11:00 AM, Manley, Tom <Tom.Manley at spectrumdsi.com> wrote:
> We are hitting this assert in scheduling.c with a win32 debug build:
> assert(ts->recursion_depth == 0 || ts->st.main == NULL && ts->st.current ==
> NULL && prev == next);
> We have tried both the release26-maint branch (assert is on line 1034) and
> the trunk (line 1037). This code will trigger the assert:
> The assert fires because ts->st.current is not NULL. This issue was also
> reported back in January
> (http://www.stackless.com/pipermail/stackless/2009-January/003838.html). It
> was mentioned in one of the replies that there was a fix but I haven't been
> able to find it. Is there a fix available? Or is it safe to comment out that
> part of the assert?

Hi Tom,

When reporting a bug, any ambiguity in its description makes isolating
it much more work.  I am not able to reproduce your problem by copying
and pasting your code into a script and running that script with a
current debug build of release26-maint.  Are you running the code in
that way, or by entering the commands directly into a running


More information about the Stackless mailing list