[Stackless] Old Error! API is broken since 2.4.3 (was: new error)

Richard Tew richard.m.tew at gmail.com
Sun Apr 18 10:52:23 CEST 2010


2010/4/13 Christian Tismer <tismer at stackless.com>:
> I came across this because I got into trouble when implementing
> Stackless support for Psyco. I think I can get along this by
> adding the necessary support functions to Psyco. This is easier
> right now than to consistently fix all Stackless versions.
> But the latter needs to be done, ASAP.

In the worst case where every point releases is fixed (e.g. 2.5.1,
2.5.2, .. etc), this will involve branching tagged revisions,
modifying the relevant branches and retagging the result.  However,
this would be doable.

What would be impractical is rebuilding the binaries, and where
applicable the installer, for each and every one of these.  It would
be best to simply add notes to the binary/installer download pages
that every obsoleted point release has a broken API that is
incompatible with Psyco, and that if someone wants a version that is
compatible with it, they should compile it themselves.  Or pay me to
do it ;-)

In any case, the latest point release for each major version should
have rebuilt binaries.  As it stands we are still pending a 3.1.2
release which I have not had a chance to do, so while I still do not
have time in the near future, if the changes were in before I did it
the release would include them and would not need to be redone.

Do you have the time to apply all the fixes?

Cheers,
Richard.



More information about the Stackless mailing list