[Stackless] "ImportError: No module named stackless" after installation on Ubuntu

Martijn van Iersel mvaniersel at gmail.com
Thu Aug 5 14:19:42 CEST 2010


Well, that is very odd. I'm on a regular i386 linux machine, not some 
weird CPU architecture.

Actually, there was no stackless.h at all in the tarball of 2.7

wget http://www.stackless.com/binaries/stackless-27-export.tar.bz2
tar -jtf stackless-27-export.tar.bz2 | grep stackless.h
-> returns nothing

I've tried it again with 2.65, even if I edit stackless.h so that 
STACKLESS is always defined, I'm still getting that ImportError.

regards,
Martijn

On 08/05/2010 10:23 AM, Richard Tew wrote:
> On Thu, Aug 5, 2010 at 2:37 AM, Martijn van Iersel<mvaniersel at gmail.com>  wrote:
>    
>> I'm trying to install stackless python on Ubuntu 10.04, but it doesn't seem
>> to be working. Here is what I tried:
>>      
> Sorry, I meant to reply to this when I got into work this morning, but forgot.
>
> If you compile the Stackless source, and the stackless module is not
> present, then this is most likely because your platform is not
> supported.
>
> This may be because the architecture has no hard switching support
> (assembly language code to change the stack pointer), or it may be
> that whatever architecture it has needs to be added for the hard
> switching support that applies to it.
>
> The support detection is here:
>
>    http://svn.python.org/projects/stackless/branches/release27-maint/Stackless/stackless.h
>
> The accompanying hard switching support inclusion is here:
>
>    http://svn.python.org/projects/stackless/branches/release27-maint/Stackless/platf/slp_platformselect.h
>
> Cheers,
> Richard.
>
> _______________________________________________
> Stackless mailing list
> Stackless at stackless.com
> http://www.stackless.com/mailman/listinfo/stackless
>
>    




More information about the Stackless mailing list