[Stackless] when i compile the stackless-2.6.5 , i came to the Error 139

Richard Tew richard.m.tew at gmail.com
Fri Dec 17 13:32:17 CET 2010


2010/12/17 刘连响 <notedit at gmail.com>:
> "gcc -pthread  -Xlinker -export-dynamic -o python \
> Modules/python.o \
> libpython2.6.a -lpthread -ldl  -lutil   -lm
> libpython2.6.a(posixmodule.o): In function `posix_tmpnam':
> /usr/local/src/python-2.65/./Modules/posixmodule.c:7207: warning: the use of
> `tmpnam_r' is dangerous, better use `mkstemp'
> libpython2.6.a(posixmodule.o): In function `posix_tempnam':
> /usr/local/src/python-2.65/./Modules/posixmodule.c:7162: warning: the use of
> `tempnam' is dangerous, better use `mkstemp'
> Segmentation fault
> make: *** [sharedmods] Error 139

Hi,

It looks like your compiler is crashing, and you haven't even finished
compiling Stackless yet. If this is the case, it would be a problem
with your development environment.  Is this a possibility?

Cheers,
Richard.



More information about the Stackless mailing list