[Stackless] Distutils test Crazyness

Richard Tew richard.m.tew at gmail.com
Wed Feb 24 21:48:34 CET 2010

On Thu, Feb 25, 2010 at 8:11 AM, Ariel Ben Yehuda <ariel.bys at gmail.com> wrote:
> test_distutils
> /usr/bin/ld: cannot find -lpython2.6
> collect2: ld returned 1 exit status
> test test_distutils failed -- errors occurred; run in verbose mode for
> details
> ...
> # # I don't think you need rocket science to understand why test_distutils
> failed
> # # --- it tried to link to libpython2.6, which wasn't yet installed.

Hi Ariel,

The short answer is that this is correct behaviour.

The long answer is that in order to determine if an error or failure
in Stackless is actually an error or failure IN Stackless, you need to
do the same operations with standard Python.  If the problems
observed, happen both in standard Python and in Stackless Python, then
Stackless is working fine and standard Python is not.

I do not recall if I ran the unit tests when I checked in the last
merge from standard Python, but I believe I would have.  However, I
just ran the unit tests against a fresh export of both standard and
Stackless Python, and they both exhibited the same failure in
distutils for me.

We need to document this somewhere.


More information about the Stackless mailing list