[Stackless] Installing Stackless on OS X 10.5 Reply | Peter Inglesby to stackless

Peter Inglesby peter.inglesby at googlemail.com
Mon May 17 22:31:26 CEST 2010


Hi,

It looks like I'm using libssl 0.9.7:

/usr/lib:$ ls -l libssl.*
-rwxr-xr-x  1 root  wheel  915632 23 Nov 04:59 libssl.0.9.7.dylib
-rwxr-xr-x  1 root  wheel  223280 25 Nov  2007 libssl.0.9.dylib
lrwxr-xr-x  1 root  wheel      18 21 Feb  2008 libssl.dylib ->
libssl.0.9.7.dylib

There are no libssl files in /usr/local/lib.

Thanks again,

Pete.

On 17 May 2010 09:31, Aleksandar Radulovic <alex at a13x.net> wrote:

> Hi,
>
> Check /usr/lib/libssl.*, that should give you some information on
> which versions are those. Check if you have them in /usr/local/lib
>
> Unfortunately, I don't have Leopard installed anywhere so I cannot
> test it (the package was built on 10.6 but built to support 10.5 as
> well..
>
> -alex.
>
> On Sun, May 16, 2010 at 2:44 PM, Peter Inglesby
> <peter.inglesby at googlemail.com> wrote:
> > I may have used MacPorts in the past - there's lots of stuff in
> > /opt/var/local/macports.  However, port is not in my path, and
> ~/.macports
> > is empty.  Equally, I don't recall having installed any extra ssl
> libraries
> > - although I may have done!  How can I find out which ssl library version
> I
> > have?
> >
> > Thanks for your help.
> >
> > Pete.
> >
> >
> > On 15 May 2010 21:57, Aleksandar Radulovic <alex at a13x.net> wrote:
> >>
> >> Hi,
> >>
> >> I built the installer for OS X, and it linked against standard libs in
> >> standard locations. This is not related to stackless per se, it's
> >> related to the way python itself is built. I remember having a problem
> >> building python for HP-UX and linking against the correct ssl
> >> libraries.
> >>
> >> Do you use MacPorts or Fink? Did you install any extra ssl libraries?
> >> Which ssl library version do you have?
> >>
> >> I have installed the built Stackless 2.6.5 on several OS X machines
> >> (although, 10.6) and it works.
> >>
> >>
> >> -alex
> >>
> >> On Sat, May 15, 2010 at 4:43 PM, Peter Inglesby
> >> <peter.inglesby at googlemail.com> wrote:
> >> > I've tried installing Stackless 2.6.5 on OS X 10.5 with
> >> > stackless-2.6.5-macosx10.5-2010-03-24.dmg linked to from
> >> > http://zope.stackless.com/download/sdocument_view.
> >> >
> >> > However, I can't use hashlib:
> >> >
> >> >>>> import hashlib
> >> > Traceback (most recent call last):
> >> >   File "<stdin>", line 1, in <module>
> >> >   File
> >> >
> >> >
> "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/hashlib.py",
> >> > line 136, in <module>
> >> >     md5 = __get_builtin_constructor('md5')
> >> >   File
> >> >
> >> >
> "/Library/Frameworks/Python.framework/Versions/2.6/lib/python2.6/hashlib.py",
> >> > line 63, in __get_builtin_constructor
> >> >     import _md5
> >> > ImportError: No module named _md5
> >> >
> >> > Is there a problem with the .dmg or could I have done something wrong?
> >> >
> >> > Thanks in advance for any help.
> >> > _______________________________________________
> >> > Stackless mailing list
> >> > Stackless at stackless.com
> >> > http://www.stackless.com/mailman/listinfo/stackless
> >> >
> >>
> >>
> >>
> >> --
> >> a lex 13 x
> >> http://www.a13x.info
> >>
> >> _______________________________________________
> >> Stackless mailing list
> >> Stackless at stackless.com
> >> http://www.stackless.com/mailman/listinfo/stackless
> >
> >
> > _______________________________________________
> > Stackless mailing list
> > Stackless at stackless.com
> > http://www.stackless.com/mailman/listinfo/stackless
> >
>
>
>
> --
> a lex 13 x
> http://www.a13x.info
>
> _______________________________________________
> Stackless mailing list
> Stackless at stackless.com
> http://www.stackless.com/mailman/listinfo/stackless
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://www.stackless.com/pipermail/stackless/attachments/20100517/ad12d110/attachment.htm>


More information about the Stackless mailing list