<!DOCTYPE html PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN">
<html>
<head>
  <meta content="text/html;charset=ISO-8859-1" http-equiv="Content-Type">
</head>
<body bgcolor="#ffffff" text="#000000">
OK looked at asyncore and at my code. A relaxing weekend helped me to
quickly figure out what's wrong.<br>
<br>
I am several steps further ahead in the issues of scheduling and
locking.<br>
<br>
Running into the problem that I am trying to put None into a channel,
finding that the receiver never receives anything and hence keeps
waiting forever.<br>
<br>
Is this supposed to happen? (so should I workaround or file a bug?)<br>
<br>
Paul<br>
<br>
<br>
Richard Tew wrote:
<blockquote
 cite="mid952d92df0702241337r2dbf6c13m33f05644dd2ef6b3@mail.gmail.com"
 type="cite">
  <pre wrap="">On 2/24/07, Paul Sijben <a class="moz-txt-link-rfc2396E" href="mailto:sijben@eemvalley.com">&lt;sijben@eemvalley.com&gt;</a> wrote:
  </pre>
  <blockquote type="cite">
    <pre wrap="">What I can not find in the code is how the real socket is addressed. I
need to get recvfrom working which ought to be simple once I understand
how it works ;-)
    </pre>
  </blockquote>
  <pre wrap=""><!---->
You need to look at asyncore :-)

Richard.

_______________________________________________
Stackless mailing list
<a class="moz-txt-link-abbreviated" href="mailto:Stackless@stackless.com">Stackless@stackless.com</a>
<a class="moz-txt-link-freetext" href="http://www.stackless.com/mailman/listinfo/stackless">http://www.stackless.com/mailman/listinfo/stackless</a>
  </pre>
</blockquote>
<br>
<pre class="moz-signature" cols="72">-- 
Paul Sijben                            tel: +31334566488
Eemvalley Technology               fax: +31334557523
the Netherlands                        <a class="moz-txt-link-freetext" href="http://eemvalley.com">http://eemvalley.com</a>    
</pre>
</body>
</html>