<br>On Sunday, November 20, 2011, Darren Govoni <<a href="mailto:darren@ontrenet.com">darren@ontrenet.com</a>> wrote:<br>>  I am trying to build a compatible stackless python using stackless 2.6.5.<br>> I have python 2.6.6 updated on my system with many packages.<br>
><br>> I can build a stackless executable but it doesn't pick up many packages,<br>> like multiprocessing, etc.<br><br>Not sure I understand what packages you mean and how it is not picking em up.<br><br>> Also, I get this error in the build:<br>
><br>> Compiling /usr/local/lib/python2.6/xml/sax/saxutils.py ...<br>> Compiling /usr/local/lib/python2.6/xml/sax/xmlreader.py ...<br>> Compiling /usr/local/lib/python2.6/xmllib.py ...<br>> Compiling /usr/local/lib/python2.6/xmlrpclib.py ...<br>
> Compiling /usr/local/lib/python2.6/zipfile.py ...<br>> make: *** [libinstall] Error 1<br><br>Do the Stackless unit tests pass for you?  What about the Python regression tests?  If these both pass, then I cannot tell you why this generic python build step fails.  I expect it to be something related to your local system.  If you can debug it and do some verbose output to see why it fails, feel free to post that to the list.<br>
<br>> I am running ubuntu 10.04 64bit. I want stackless to work with all my<br>> existing packages. Is it possible?<br><br>Whether it is, is beyond the scope of Stackless.  This is a general Python problem, how to install two versions of the same interpreter and have them share the same lib directories.  Yes, it is possible.  No, unfortunately I do not know how offhand.  But keep in mind that Stackless has modified and extra lib files.  You would have to deal with that, all in all, unsupported..<br>
<br>Cheers,<br>Richard.